Fixing the Err 01 issue on a Canon EOS with lens adapter

posted in Journal

Fixing the Err 01 issue on a Canon EOS with lens adapter

This morning I’ve received a lens adapter I’ve ordered to mount my good ol’ Zuiko lenses on my Canon EOS body. Since I’m on a budget, I’ve bought the cheapest one. Those are usually made of low quality material and may have parts that need a bit of polish to actually work.

When mounted, this adapter push on a pin placed at 10 o’clock on the camera’s bayonet mount. I read somewhere on a forum that this element is supposed to be the AF activation switch. When the lens ring is pushing it clockwise the camera will lock the mirror up and refuse to shoot. The only on-screen information will be “ERR 01“. Some people are fixing the problem by slightly un screwing the lens adapter. It works but you’ll risk to lose your lens while performing quick aperture and focus ring movement since your adapter won’t be locked into the bayonet.

The best solution is to file down the part of the adapter that is pushing the pin. It takes a minute to be done and you don’t have to bother about scratching your adapter. Here is a series of photos showing the part that needs to be filed. I hope It will help you.

ERR 01

The message indicating a lens malfunction.

The *AF activation switch* is located at 10 o`clock on the bayonet mount ring.

The *AF activation switch* is located at 10 o`clock on the bayonet mount ring.

The pin (outlined in the picture) should be pushed clockwise.

The pin (outlined in the picture) should be pushed clockwise.

You will have to file down that edge.

You will have to file down that edge.

More details on what needs to be filed down.

More details on what needs to be filed down.

Enjoy your  lenses ;-)

Leave a Reply

Your email address will not be published. Required fields are marked *